Search results

  1. P

    Koso temp sensors question

    I made this more difficult on myself as always. I have one large connector that the whole engine harness goes through. So if I pull the motor, I only have 1 wiring connection to worry about. Because of this, the sensor wires are much longer than they should be. My ecu uses different sensors, and...
  2. P

    Development videos

    I just measured the ride height and moved it up considerably after the Sears outing. I'm about as high as I want to go in the rear, I think 4.5". I think the front is 4.25". I'm going to need to raise the hood and front of the body. I don't think I want to raise the chassis much more. I also...
  3. P

    Development videos

    Yes, stock C4 hubs. Unfortunately I don't even have big power yet. 385 at the wheels when it was tuned last month. But that's with only 6psi. I'm finally understanding just how the turbos work, which is purely mechanical settings for the boost. I thought mechanically the low setting was...
  4. P

    Development videos

    I trailer it there. I run with the 3Balls guys and camp in the paddock with friends. It happens they go to Grattan the most. Plus I'm a lifetime member so I don't pay an entrance fee for their track days. You're right tho, it's a long way to go for early shakedowns like this. I won't be doing...
  5. P

    Development videos

    I have been working really hard getting the car drivable. I thought about giving an update since the last novel in my build thread, but that's too overwhelming to think about. So this is easier. I have an appointment with the local BMV inspection set up for next week. I took the car to Grattan...
  6. P

    Koso temp sensors question

    I am using the Koso dash and have a Lexus 1UZ engine. When I turn on the ignition the instruments say the water and oil temps are roughly 135 and 155. When the engine is stone cold. I called Koso, they asked if I extended the wires. I may have, that was a long time ago. Well, the sensors are...
  7. P

    Has anyone done the first start and go kart in the same night?

    I did :D Thanks Troy for all your help!! First start! First go kart pt 1 First go kart pt 2 First go kart pt 3 Fran, that engine is good after all! I first tried starting it over Christmas break. It has been a comedy of errors ever since. Maybe in my build log I'll detail everything I...
  8. P

    Safely loading SLC onto flatbed or trailer?

    I got mine onto a friend's flatbed trailer far easier than I expected. A pair of 2x12 boards that were about 6' long were placed on the relatively short ramps. It was enough to keep the nose (fully raised up) from contacting the ramps. I have a tow hook similar to Howard's. The winch is pretty...
  9. P

    First start attempt

    I saw some pinched hoses in there, I'm hoping that's the problem! Rerouting and remount in everything really wasn't as bad as I feared, and I didn't even have to move the tub! I was afraid I was going to have to chop it to pieces. There are still some components to put back in place, but I liked...
  10. P

    First start attempt

    No, it's cheap repurposed pergo. I ripped it out of the house and taped it to the floor in the barn. I wasn't sure how it would work, but it's awesome. It's not nearly as cold as concrete, I can slide under the car in a breeze, and it has held up to brake fluid, oil and gas!
  11. P

    First start attempt

    I wired mine so the ecu (megasquirt 3 pro) triggers the relay. But the relay is supplied power from the rear powercell, which is an output that is not currently active. I ran that temporary wire to the relay last night to force the pumps on, but still no fuel. I made the mistake of burying the...
  12. P

    First start attempt

    Thanks for the info, guys! Once I got the new mega fuses and rewired everything, it worked! I haven't been getting any fuel, and realized the fuel pump isn't even coming on. I had some confusion in my wire labeling but it turns out there wasn't a fuse in the powercell for the fuel pump...
  13. P

    First start attempt

    Update: The battery terminal not tightened was definitely the problem, but not the only problem. After tightening the positive battery terminal, I hit the start button and the motor turned over, slowly. Once. Then everything went blank. The other problem was I had the starter wired through...
  14. P

    First start attempt

    I don't have any ground straps, but the motor and trans are rigidly mounted. Would a strap still be needed? The battery has been on a trickle charger for the whole project (I hate to think how long that has been....). The headlights are bright when they come on. As I think this through, I...
  15. P

    First start attempt

    I tried to turn over the motor for the first time tonight. I pressed the start button, the Infinity Box showed power to the Megasquirt 3 Pro, the injectors, and the starter. The starter gave a loud CLICK but the engine didn't turn over. I have a Lexus 1UZ engine. It's acting as if it's siezed...
  16. P

    Aero latch vs Quik latch

    I followed Pete's design idea and put the quick latches on the nose of my SLC. After his incident, I removed mine and placed them in the drawer. Someone may be able to devise a test under ideal conditions where they hold significant forces. Pete has proven that in the real world they are a...
  17. P

    SLC picture thread

    I painted it with VHT epoxy paint. I haven't tested it for fuel resistance yet I just poured some gas on a fiberglass part painted with this paint and it discolored a bit but didn't come off.
  18. P

    SLC picture thread

    Thanks Mesa! The wheels are 19" all around.
  19. P

    CamT's build thread

    Thanks for the shout out on the door handles. I hate to admit it but that was so long ago I forgot about having those problems. Your work is impressive and I empathize with you about getting bogged down in the details. It's easy to do, but the final product is SO much more satisfying.
  20. P

    A.J.'s SL-C build thread

    I'm not sure what the best current to run them at is. On the website, it shows the test voltage is 50mA if that helps.
Top