Sensors

Steve

Supporter
I'm now in a phase of hooking up sensors. There is an oil and coolant sensor (first picture) and an oil pressure sensor (a plastic tube). Coolant temp sensor goes into the intake manifold (second picture). Not sure where the oil pressure sensor should go. Dennis gave me an adapter for the plastic tube (third picture). Wonder if it goes in place of this fitting in the rear right part of the block (4th picture)? Where are other people putting theirs? This is a Ford Boss 302 block. I initially thought it went into this hole in the block at the front left (seen in picture 5) near where the oil filter would go but I'm wondering if that is where the oil temp sensor goes.

Any thoughts?
 

Attachments

I'm now in a phase of hooking up sensors. There is an oil and coolant sensor (first picture) and an oil pressure sensor (a plastic tube). Coolant temp sensor goes into the intake manifold (second picture). Not sure where the oil pressure sensor should go. Dennis gave me an adapter for the plastic tube (third picture). Wonder if it goes in place of this fitting in the rear right part of the block (4th picture)? Where are other people putting theirs? This is a Ford Boss 302 block. I initially thought it went into this hole in the block at the front left (seen in picture 5) near where the oil filter would go but I'm wondering if that is where the oil temp sensor goes.

Any thoughts?
I think oil temp sender is usually in the oil pan. Pressure sensor can be on the left front of the block, next to the oil filter. Some Ford Engines have provisions for locating the sender at the top of the block at the rear, behind the intake, but I don’t know if Windsors allow that.
 

Steve

Supporter
I have an Aviaid dry sump pan. It does have a -12 outlet in the pan but I haven't seen anyone using it for the oil temp.
 

DaveM

Supporter
Oil pressure line goes at left front of engine as shown in your 5th photo. I put my oil temperature sensor in the remote filter adapter plate on the left side of the block. However I have a wet sump.
 

DaveM

Supporter
Here's both the oil temperature and oil pressure connections. If you don't have this adapter plate you may have to get a longer temperature sensor and hook it into your remote filter.
 

Attachments

Tim Terry

Supporter
If it's a late model Ford Motorsport BOSS 302 block (M-6010-BOSS302), the oil pressure port is stbd rear of the block. The port front is blocked off. I have this block in my '66 Mustang.
 

Steve

Supporter
It is late model Boss 302. Purchased about 5-6 years ago. It does have a plug (4th picture) in the block in that location that looks like it would accept the plug in the third sensor. Wondering if the Oil temp sensor (1st pic) would go on the port front of the block where I started to insert the oil temp (5th pic). The fifth pic is a bit upside down, the blue cap is on the oil filter fitting.
 
Top