Need Help With Ignition Gremlins

Last Sunday, we thought we had tuned and timed the car. Tonight I fired it up and the problems returned. It only fires on 4 cylinders. Hooked up the timing ligt and nothing on #1 sparkplug. Shut the engine down and restarted it. Now all 8 fire. Tried to set the timing to 10deg BTDC and the timing jumps all over the place. Started to backfire through the mufflers and then quit.

Started it again and all 8 cylinders firing. Set timing to 10 deg again and it doesn't want to run. Put it at 20 deg and it runs. Reved it up and it doesn't move past the initial timing. Reset it to 15 and it runs but no advance.

Whats up with this?

Setup is Crane HI6 and HEI distributor.

The frustration with this car is really beating me down.
Assuming that you have checked the dist advance for free movement and is not seized-- since your car has not been started for a long period its quite likely-- I have had 'new' MSD's that have to be stripped and rebuilt before fitting, which direction can you turn the rotor assy to check mech advance- for ford it should be anti clockwise looking from top.- there is a possibility that someone has installed a chev rotor head to the dizzy.
I can move the distributor by hand and the timing changes. But when I rev the engine, it doesn't change.

I just tried it again and the car backfires through the mufflers. I'm beginning to think the distributor gear is disintegrating.
Bill, dont run the motor again until you have checked the advance system as in my previous post by hand with the cap off. I am not familiar with your Crane setup, but there is also a possibility your wiring might be wrong if its similar to an MSD system, this can cause the system to fire off the wrong end of the pickup with similar symptoms to those you describe.
My guess is that there's more to it than just advance, or the advance mechanism. If you're only getting spark on 4 cylinders (intermittantly) then there's something off upstream. Not sure if you have separate coil packs but I'd definitely check those, and, if you have a crank-fire pickup then make sure you have the right offset and spacing for the sensor.

From what I could get off the Crane site last night your distributor & HI6 system can have up to Nine '9' electronic / mechanical curves and Three '3' vacuum advance curves- also electronic. another feature is that it has an 'advance lockout' mode for crank trigger setups- which according to the pics you dont have. If the system has electronic vacuum advance as well its something that many weber users have been looking for- but does it require a vac signal to operate it, in which case its back to the dwg board.

Going by all that I would think that the system may still be in advance lockout mode which would explain the lack of advance when revved. It also has a system check built into it so that you can check the whole system by means of the light diodes which might be worth doing if you have not already done so.

Hope you did not throw the instructions & paperwork that came with system out with the garbage when you moved house- sounds like your going to need it .:)
Yes MSDs are notorious for this and IIRC MSD was partly to blame with mismatched pickup wire colors. In any case, I think your first suggestion is the best place to start, and I don't mean the manual turning of the rotor. It sounds like, with this Crane system it SHOULD be locked. Definitely try the double checking of the wiring. I have suggested this more than a few times to people and know that it has solved a lot of problems. Pay particular attention to grounds. A properly grounded system, per manufacturers instructions, is a must.
Thanks everyone. I'm going to call Crane Tech today and talk with them as well as try your suggestions tonight when I get home. This is extremely frustrating. Just seems I'm not making any progress.

And I still have all the paperwork. :)

Bill D
I had a guy who was about ready to set fire to his machine because he couldn't get the timing to "settle down". He and I spent the better part of two days pulling each individual wire out of the harnes, checking it's continuity, and hookup. We never did find a cause, but after doing all that it ran perfect. Theory is that a wire or two were not seated properly in a plug and removing them and reseating them solved the problem. Don't know if you have many connectors on there or not, but I would at least check continuity and seating of pins on everything if you don't want to, or have the tools, to remove all the wires. And I can't stress this enough. Make sure the grounds are appropriate and good.
Discovered the source of my timing gremlins!!!

I called the Crane Tech line and spoke to one of their techs. I explained my problem and the symptoms. Before I could even finish, he said I have a bad module in the distributor (its all electronic, no springs or weights for timing advance). He said its happened before and can be fixed. He wants me to ship it back to them for repair. GOD DO I FEEL RELIEVED!!

He assured me it isn't the box.

Thanks to all for all the help.

Bill D

Doug S.

The protoplasm may be 72, but the spirit is 32!
Lifetime Supporter
Wow, that's great news, Bill!

What a shame he wouldn't just ship you a replacement dizzy!!

So, onward through the fog........

Hey, stick with it Bill. It's a relief when you know it isn't something that you've stupidly stuffed up or omitted yourself. Of course it's annoying that you weren't sent a good unit in the first place, but at least you can look forward to a good rumble when you get it all back together.